If this blog helped you in any way (professionally), please donate a dollar here

Saturday, October 4, 2008

TECH-COM TV Tuner card on Linux



I finally got TV working (I had a TECH-COM SSD-670) on Ubuntu 8.04 LTS Desktop edition and what a struggle was that!

Okay I'm enumerating my experience in short for others :----
I downloaded
XAW-TV and SCANTV... so these are the basic requirements.
(or TV-Time perhaps; but I didn't try that)
Then run these :

sudo rmmod saa7134_alsa
sudo rmmod saa7134_dvb [ Optional since, DVB module might not be loaded: check out lsmod ]
sudo rmmod saa7134
sudo modprobe card=3 tuner=69
awright! Now everything should work fine and if you don't have sound it's because the Line-In is muted. Un-Mute that from the main volume controls.

With a bit of modifications you can get it working. Say the
card=3 and tuner = 69;; these numbers vary depending on your card and Tuner.


To scan channels and store the xawtv configuration; Goto your /home/
folder and do this:

scantv -a -C /dev/vbi0 -c /dev/video0 -o .xawtv
Provided the modprobe above produced a video device at /dev/video0 and vbi at /dev/vbi0
To know what devices were made:

dmesg
and find from the end.

Okay so configuration file created... now run XAW... works like a charm.


Now the final part: to get Ubuntu to load the modules every time do this:
sudo gedit /etc/modprobe.d/options
Now... add the line at the end (with any comments [ comments start with hash ] )

options saa7134 tuner=3 card=69
install saa7134 /sbin/modprobe --ignore-install saa7134

Now this is what I did for my card.. edit where-ever necessary.

No comments:

Post a Comment